Discussion:
[tw] [Noteself] load error using empty.html ($tw.boot.boot is not a function)
Add Reply
Lost Admin
2017-08-07 16:33:36 UTC
Reply
Permalink
Raw Message
In my slow but continuing effort to built a full Noteself supporting
environment I noticed something odd.

If I go to https://noteself.github.io/online/, there is a nice quick
Loading and everything shows up ready to go after the word "loading" turns
green. It all happens with a single call to the URL.

If I download the empty.html from https://noteself.github.io/ (a button
near the bottom of the page) and put the resulting file on my own static
web server (https://wiki.suntrap.ca/noteself.html), there is a series of
several reloads from the server before it finally shows up. I have
confirmed this with both the Firefox developer console and the server logs
on wiki.suntrap.ca.

In addition, the console log in the developer tools of Firefox shows an
error each time there is a reload. The error (tabs expanded) is below.



I suspect there is a bug of some sort in the empty.html that is not in the
"online" version used in noteself.github.io.
--
You received this message because you are subscribed to the Google Groups "TiddlyWiki" group.
To unsubscribe from this group and stop receiving emails from it, send an email to tiddlywiki+***@googlegroups.com.
To post to this group, send email to ***@googlegroups.com.
Visit this group at https://groups.google.com/group/tiddlywiki.
To view this discussion on the web visit https://groups.google.com/d/msgid/tiddlywiki/4790fcb9-ef70-4952-bdd6-439584e0fefc%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Lost Admin
2017-08-07 16:54:56 UTC
Reply
Permalink
Raw Message
I have now tried this with Firefox 54, MS Edge, and IE 11. IE 11 does not
exhibit the reloading behavior.

*Firefox (repeating in access log)*

"GET /noteself.html HTTP/1.1" 200 404453 "-" "Mozilla/5.0 (Windows NT 10.0;
WOW64; rv:54.0) Gecko/20100101 Firefox/54.0"

*Edge (repeating in access log)*

"GET /noteself.html HTTP/1.1" 200 245760 "-" "Mozilla/5.0 (Windows NT 10.0;
Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116
Safari/537.36 Edge/15.15063"

*IE 11 (only once in access log)*

"GET /noteself.html HTTP/1.1" 200 404453 "-" "Mozilla/5.0 (Windows NT
10.0; WOW64; Trident/7.0; rv:11.0) like Gecko"

I don't have chrome at home to test with.
--
You received this message because you are subscribed to the Google Groups "TiddlyWiki" group.
To unsubscribe from this group and stop receiving emails from it, send an email to tiddlywiki+***@googlegroups.com.
To post to this group, send email to ***@googlegroups.com.
Visit this group at https://groups.google.com/group/tiddlywiki.
To view this discussion on the web visit https://groups.google.com/d/msgid/tiddlywiki/014fcf24-abd9-4e11-91b8-3a8ce8925de3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Lost Admin
2017-08-08 12:26:32 UTC
Reply
Permalink
Raw Message
Now that I'm at work, I can add Chrome 59 to my list. It works without
issue.

I'm thinking it might be something to do with either Firefox in general or
my particular set-up of Firefox. Can someone else see if it's doing the
same multiple-reload thing for you too or if it's just me?
--
You received this message because you are subscribed to the Google Groups "TiddlyWiki" group.
To unsubscribe from this group and stop receiving emails from it, send an email to tiddlywiki+***@googlegroups.com.
To post to this group, send email to ***@googlegroups.com.
Visit this group at https://groups.google.com/group/tiddlywiki.
To view this discussion on the web visit https://groups.google.com/d/msgid/tiddlywiki/350066cf-1367-489f-b4f2-2b4034aaa3c7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Lost Admin
2017-08-08 13:09:47 UTC
Reply
Permalink
Raw Message
I need to correct my assessment with Chrome. Although Chrome does not
exhibit the multiple-reload behavior, it does report the same error on the
javascript console:

<Loading Image...>
Post by Lost Admin
Now that I'm at work, I can add Chrome 59 to my list. It works without
issue.
I'm thinking it might be something to do with either Firefox in general or
my particular set-up of Firefox. Can someone else see if it's doing the
same multiple-reload thing for you too or if it's just me?
--
You received this message because you are subscribed to the Google Groups "TiddlyWiki" group.
To unsubscribe from this group and stop receiving emails from it, send an email to tiddlywiki+***@googlegroups.com.
To post to this group, send email to ***@googlegroups.com.
Visit this group at https://groups.google.com/group/tiddlywiki.
To view this discussion on the web visit https://groups.google.com/d/msgid/tiddlywiki/1eca6270-a54e-485e-aea5-18c19793a545%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Loading...